Configure Active Directory integration with LDAP for login

I’m installing the gatling enterprise on an Openshift, so we’ve created all the necessary resources, but when you apply the Frontline.conf on the resources, it doesn’t recognize special characters in the password, and if we put them in quotes, it doesn’t recognize the credentials, we’ve done the tests with ldapsearch and it has worked correctly, the problem is when we apply it in our Openshift. The outputs we receive in all the cases we have tested are:

FRONTLINE_HOME is set to /opt/frontline
[ERROR] i.g.f.app.Main - API server failed to start
com.typesafe.config.ConfigException$Parse: frontline.conf @ file:/opt/frontline/conf/frontline.conf: 12: Expecting end of input or a comma, got ‘!’ (Reserved character ‘!’ is not allowed outside quotes)
(if you intended ‘!’ (Reserved character ‘!’ is not allowed outside quotes) to be part of a key or string value, try enclosing the key or value in double quotes, or you may be able to rename the file .properties rather than .conf)

If we change the type of shipment it shows this other error:

c.d.o.d.a.c.AllNodesFailedException: Could not reach any contact point, make sure you’ve provided valid addresses (showing first 1 nodes, use getAllErrors() for more): Node(endPoint=/127.0.0.1:9042, hostId=null, hashCode=dcd463f): [com.datastax.oss.driver.api.core.connection.ConnectionInitException: [s5|control|connecting…] Protocol initialization request, step 1 (OPTIONS): failed to send request (io.netty.channel.StacklessClosedChannelException)]

Hi,

You seem to have 2 errors:

  1. In your frontline.conf file, line 12, you have a malformed String. You can usually write bare string in HOCON without wrapping them with double quote, but here you’re trying to use the ! reserved char so you MUST wrap in double quotes, eg "foo!".
  2. Your Gatling Enterprise server cannot connect to your Cassandra database. It means that:
  • either your database is down;
  • or the address you’ve configured in frontline.conf is incorrect;
  • or there’s some firewall in-between that blocks traffic

If you can’t solve your problems with these information, I recommend that you reach out on the private Jira Service Desk support.

Hello Geraldo,

Just a heads up that I’ve sent you an invitation to the Private Jira Service Desk.

All the best,
Pete

Hello everyone, I have already asked the owner of the enterprise account to create the ticket in Jira, but to see if perhaps they could help me I give a little more detail:
in the Opaque secret type resource I have created the following frontline.conf:
frontline.licenseKey = MyLicence
frontline.security.superAdminPassword = “P@ssw0rd”
frontline.security.secretKey = MySecretkey
frontline.cassandra.contactPoints = [{
host = gatling-cassandra.gatling.svc.cluster.local,
port = 9042
}]
frontline.ldap.host = myCompany.com
frontline.ldap.port = 389
frontline.ldap.baseDn = “OU=mybase,OU=mybase,DC=myCompany,DC=com”
frontline.ldap.distinguishedName = “CN=MyCN,OU=MyCN,OU=Corporate,DC=myCompany,DC=com”
frontline.ldap.password = P@ssw0rdWith!Contains
frontline.ldap.personObjectClass = person
frontline.ldap.mailAttribute = mail

or also

frontline.ldap = {
host = myCompany.com
port = 389
baseDn = “OU=mybase,OU=mybase,DC=myCompany,DC=com”
distinguishedName = “CN=MyCN,OU=MyCN,OU=Corporate,DC=myCompany,DC=com”
password = P@ssw0rdWith!Contains
personObjectClass = person
mailAttribute = mail
}

I changed the Pass with quotation marks, base64 and with single quotation marks and in no case does it recognize the password