Error during packaging JAR for FrontLine

Hi Community,

We have a problem in our team that only happens on some workstations and we’re trying to figure out what can be the cause.

During the maven build, in the package stage while building the shaded JAR, we get the following error:

[ERROR] Failed to execute goal io.gatling.frontline:frontline-maven-plugin:1.2.1:package (default) on project MyProject: Execution default of goal io.gatling.frontline:frontline-maven-plugin:1.2.1:package failed: Failed to process zip entry 'license/' with action$Unpacker@438496a9: File C:\Users\myuser\AppData\Local\Temp\frontline9061542107390020153\license exists and is not a directory. Unable to create directory.

We tried reimporting all Gatling dependencies, compared Maven version with workstations that do not get this error and didn’t come up with a solution.
Do you have any idea what can be the cause and how to fix it?


Hi @Chikolad,


  1. frontline-maven-plugin is deprecated.
  2. Last version of this (deprecated) frontline-maven-plugin is 1.2.3

The error states that one of your dependency has a license file and other has a license directory.
As you’re running under Windows (C:\Users\...), it’s a case insensitive file system.

Can I assume it’s only one and same project?

Windows vs MacOS vs linux?

If OS is not the issue, try cleaning your maven cache (delete the ~/.m2/repository directory)

I hope this helps!


Thanks @sbrevet!

Yes, the same project.

All machines are Windows 10.
We also tried deleting the m2 repository and it didn’t work.

If the frontline-maven-plugin is deprecated, should we switch to gatling-maven-plugin? Is it a trivial switch?

Yes, gatling-maven-plugin is the way to go. But ensure that your Gatling Enterprise server is recent enough: frontline-maven-plugin was mandatory for very old version of FrontLine (former name of Gatling Enterprise).

And about the switch, except for the breaking change (you have to add the scala maven plugin yourself as we provide Java DSL now) we didn’t receive any complaint.
You can check the documentation of the gatling-maven-plugin for more information.


Thank you @sbrevet, I will examine this option.
As for getting the current plugin to work, if you have any other ideas please share :slight_smile: I will try to figure out if there’s a collision between the “license” dependencies.