[gatling jenkins plugin] Build error

Hi Gregory,

I tried to reproduce (note that you have to -Dgatling.simulation, not -Dgatling.simulations) but it worked fine.
Are you sure that you properly renamed the file AND the class name inside the file (those don’t have to be the same in scala)?


I uploaded my code :

mvn gatling:execute -Pmobile is ok
mvn gatling:execute -Pmy is ko


In your file MySimulation.scala the package is simulations.basic, so if you want to launch this simulation the full class name is simulations.basic.MySimulation. Be careful, class name and package in scala are not correlated to the file name and directory.

OK, found it!

This is a Zinc bug (the incremental scala compiler we’ve been using recently): it doesn’t properly refresh.
The good news is that it has already been fixed!

You can:

  • use the 1.4.0 snapshot that ships a more recent version of Zinc
  • perform a clean (but you lose incremental compiling) mvn clean gatling:execute
    If that’s really a blocker, we’ll have a 1.3.5 with the new Zinc.




I don’t think this is a Zinc related bug. In the file MySimulation.scala the package is simulations.basic, so the full class name is simulations.basic.MySimulation not basic.MySimulation

Thx a lot.

I will add the clean (I usually always do it, I don’t know why I missed it this time).

Thx a lot for your support and have a good Devoxx (if it’s not ended for you)

Ouch, the clean does not the trick… I’m gonna try the 1.4.0-SNAPSHOT

Wonder if I messed up.
But Grégory Coutant is right: your package is wrong!

Ok finally fixed!

I renamed the packages tp simulations.basic and fixed the maven profiles simulation property to simulations.basic.XXX

What is really weird is that it was working for the BasicExampleSimulation which, if I understood well, was wrong.