Getting 500 internal on second run

My login works fine on first run. On second run, it gets 500 internal error and I need to wait for expiration before I can run successfully again and not getting 500 internal during login.

On my browser, I can login then kill browser, then login again and I don't get a 500 error via browser.

Any ideas?

Hi Jamie,
I think, you didn’t disable the caching globally. You need to do this.

I have placed the disable caching [.disableCaching]. I changed the headers a bit, then it worked, then again getting 500 after 1st run.


POST /auth/realms/realmname/login-actions/request/login?code=return_codehash HTTP/1.1
Upgrade-Insecure-Requests: 1
Origin: https://domain
Connection: keep-alive
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,/;q=0.8
Cache-Control: max-age=0
Content-Type: application/x-www-form-urlencoded
Accept-Language: en-US,en;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Host: domain
Referer: https://domain:443/auth/realms/realmname/protocol/openid-connect/auth?client_id=myclientid&redirect_uri=https%3A%2F%2Fdomain%2Fonlinetransaction%2F&state=27f669ee-57aa-4738-8ea0-01875e549f0b&response_type=code
Cookie: BIGipServerPOOL_TESTSVR_80=1428822700.20480.0000
Accept-Encoding: gzip, deflate
Content-Length: 228


Just an update. I changed the version of Chrome to 61 then it worked. I suppose another run will have problems. So there’s something going on that’s not flushed.