java.lang.UnsatisfiedLinkError: /tmp/swoval-jni/

Hello gatling Users

I am running my tests from Linux , but hitting into below issue :

Compilation crashed

java.lang.UnsatisfiedLinkError: /tmp/swoval-jni/ /tmp/swoval-jni/ wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)

at java.base/java.lang.ClassLoader$NativeLibrary.load0(Native Method)

at java.base/java.lang.ClassLoader$NativeLibrary.load(

at java.base/java.lang.ClassLoader$NativeLibrary.loadLibrary(

at java.base/java.lang.ClassLoader.loadLibrary0(

at java.base/java.lang.ClassLoader.loadLibrary(

at java.base/java.lang.Runtime.load0(

at java.base/java.lang.System.load(

at com.swoval.runtime.NativeLoader.loadPackaged(

at com.swoval.runtime.NativeLoader.loadPackaged(

at com.swoval.files.NativeDirectoryLister.(

… 38 common frames omitted

Due to restricted sytem access , tmp does not have exec permisison . Is there a way this can be resolved . i am using 3.3.1 / 3.1.3 version of gatling .

i have done whats mentioned in this post!topic/gatling/Gj4EdAEoq-E with reference to setting up new path .


Try setting the “swoval.tmpdir” System property to the absolute path of a directory that’s not mounted as noexec.

Thanks Stephane for quick responses . It worked . For any one who might face this issues see below for what i did in bin dir of gatling bundle .


JAVA_OPTS="-Djna.tmpdir=$HOME/tmp -Dswoval.tmpdir=$HOME/tmp" ./