Resetting my router to get the same results (or the SUT?)

I run a simulation and it works just fine, but the second time I run it I get timeouts (and shitty response times).
restarting my (wifi router) I get no timeouts (and good response times).
this pattern (in my opinion) seems to be that my ISP is the problem.

If I have a scenario which is very simple:

`

package no.site

import io.gatling.core.Predef._
import io.gatling.core.scenario.Simulation
import io.gatling.http.Predef._
import scala.concurrent.duration._

class idpSimulation extends Simulation{

  val httpConf = http
    .baseURL("https://id.maersk.dk/ids")
    .acceptEncodingHeader("gzip,deflate")
    .headers(Map("Content-Type" -> "application/x-www-form-urlencoded; charset=utf-8"))
    .authorizationHeader("Basic bW9iaCxlX2NsaWVudFptb2JpbGVfc2VjcmX0")
    .disableUrlEncoding

  val scn = scenario("Scenario")

    .feed(csv("data/memberid.csv").random)

    .exec(
      http("getToken")
        .post("/connect/token")
        .body(StringBody("username=${MemberId}&password=passxyz&scope=legacy&proxy=http%3B%2Z%2Flocalhost%3A88)8&grant_type=password"))

        .asFormUrlEncoded
        .check(jsonPath("$.access_token").exists.saveAs("token"))  

  setUp(scn.inject(constantUsersPerSec(150) during (20 seconds))).protocols(httpConf)

`

My question is (I hope I do not get an answer that suggests to check my ISP).

Could this be Gatling, or is this the SUT or my Broadband).

BTW: the SUT is not under very certain stress (CPU-wise).

Do I need to close the session(per session) or disable keep alive(?) to find the source of the challenge?
which strategy would you fetch to deal with the issue?