Upgrade Syntax Problem - 2.3.1 to 3.0.0


I’m getting this:
Warning: Unknown option -m

I’m executing gatling like this.
/opt/gatling/bin/gatling.sh -m -rf ${CONTAINER_GATLING_RESULTS_DIR}

If I remove “-m” it then prompts me and asks me for a Description.

Given this is an automation script, with no humans then this is a regression and I need to know how to not prompt for any Description.

Many thanks,

First, don’t upgrade to 3.0.0, latest is 3.0.3!

Then “-m” was indeed dropped.
Mute behavior is automatically triggered as soon as you pass the parameter to set the name of the simulation class you want to run.


Hi Stephane,

Thanks for this guide. I’ve updated my syntax to use “-s” now, and specifying my Simulation ClassName :slight_smile:

Problem resolved.

Many thanks,