Can't upgrade Gatling version from 2.2.3 to 2.3.1 in Maven project


We’ve been trying for a long time to upgrade our project from Gatling 2.2.3 to version 2.3.1. Unfortunately we are always running in the same error.

[DEBUG] [C:\Progra~1\Java\jdk1.8.0_101\jre\bin\java, -jar, C:\Users\Zoe\AppData\Local\Temp\gatlingbooter8345810722978821538.jar, io.gatling.compiler.ZincCompiler, C:\Users\Zoe\AppData\Local\Temp\gatling-maven-plugin-5777009354460983065.args]
error: java.lang.AbstractMethodError: scala.reflect.internal.SymbolPairs$Cursor.matches(Lscala/reflect/internal/Symbols$Symbol;)Z


My coworkers reproduce the same error on their machines.

We launch our tests with this command line:

gatling:execute -Dgatling.simulationClass=simulations.CheckCheck -X

POM in attachment.

If anyone has an idea… (other than clean / install / deleting our .m2 folders, which we did of course!)

Thanks in advance.

zzz-pom.xml (6.28 KB)

Please check the migration guide. Gatling 2.3 requires Scala 2.12. You most likely need to upgrade your version of gatling-maven-plugin to 2.2.4, or make sure you only pull artifacts for Scala 2.12 and not 2.11.

Sure, we checked both already (Scala version in POM is 2.12.2 and Gatling Maven Plugin version is 2.2.4, see attachment). But the problem is occurring anyway.