Command line request bodies parameter not working

Hello Folks,

I have Gatling in IntelliJ and its working great.!! I have copied project and trying to run it from command line. It works but seems it does not recognize my request bodies parameter (-bf command argument).

Version: Gatling 2.2.0

My Command line looks like this: For brevity I have excluded my $CLASSPATH. The parameter request body files -bf is not working. My program shows ERROR in log- “could not find request body”.

java -Dgatling.charting.noReports=false -Dgatling.http.enableGA=false -server -XX:+UseThreadPriorities -XX:ThreadPriorityPolicy=42 -Xms512M -Xmx512M -Xmn100M -XX:+HeapDumpOnOutOfMemoryError -XX:+AggressiveOpts -XX:+OptimizeStringConcat -XX:+UseFastAccessorMethods -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CMSParallelRemarkEnabled -Dgatling.http.connectionTimeout=250000 -Didea.launcher.port=7532 -Dfile.encoding=UTF-8 -classpath “$CLASSPATH” -s com.myproj.WebTest -bf /Users/jay_ken/workspace/gatling-2.2.0/out/production/gatling-2.2.0

On File system I have bodies stored under ~


I tried giving all the combinations such as gatling-2.2.0/user-files OR ~/…/gatling-2.2.0/user-files**/bodies** etc. but did not work.

Wondering what I am missing?

Jayant Kenjale

-bf, really?

Thanks for pointing to right documentation. It worked.