disable keep-alive

How do I disable keep-alive in my simulation?

I found that I can do this in gatling.con
with the property:


allowPoolingConnection = false     # allow pooling HTTP connections (keep-alive header automatically added)


I did set it to false, but when rebuilding the solution I get:


Enabled obsolete properties:
‘gatling.http.ahc.allowPoolingConnection’ was renamed into gatling.http.ahc.allowPoolingConnections.


Is this a problem?

Hi Magnus,

Rename the property in gatling.conf and to allowPoolingConnections it’ll work.




What about allowSslConnectionPool ?

My simulation has base url with https.