error on Gatling compilation

I am trying to setup Gatling in my test machine and getting the following error.

C:\Code>CareID_Devops\Performance\Gatling\run.bat gatling-charts-highcharts-2.1.3
C:\Code>set gatlingScriptsPath=C:\Code\CareID_Devops\Performance\Gatling
C:\Code>set GATLING_HOME=gatling-charts-highcharts-2.1.3
C:\Code>set JAVA_OPTS=-Denv= -Dusers= -DrampUp= -Dduration= -Dpwd=C:\Code\CareID_Devops\Performance\Gatling
C:\Code>if “” == “” (gatling-charts-highcharts-2.1.3\bin\gatling.bat -sf C:\Code\CareID_Devops\Performance\Gatling\simulations -df C:\Code\CareID_Devops\Performance\Gatling\data -bdf C:\Co
GATLING_HOME is set to “gatling-charts-highcharts-2.1.3”
Unrecognized VM option ‘OptimizeStringConcat’
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

I am using Windows 7 32 bit machine.

Java version is -

C:\Code\gatling-charts-highcharts-2.1.3\bin>java -version
java version “1.8.0_72”
Java™ SE Runtime Environment (build 1.8.0_72-b15)
Java HotSpot™ Client VM (build 25.72-b15, mixed mode, sharing)

Could you please help me.

You run on a 32bits Windows where Oracle doesn’t provide a server JVM.
You probably already more or less figured it out as you most likely removed the “-server” option from the JAVA_OPTS in gatling.bat.

The “OptimizeStringConcat” JVM option is only available on server JVM, so you have to remove it too.