Gatling 2.0.0.M3a Maven plugin problem on Jenkins

I got a curious problem this morning.

when i run my simulation from my IDE the plugin works well.
when i run the simulation with a command line from the workspace of the jenkins job it works well

but when i run the job via the jenkins interface i got the stack below :

scala_maven_executions.MainWithArgsInFile C:\Tmp\scala-maven-8694682155410557868.args


java.lang.NoClassDefFoundError: and
Caused by: java.lang.ClassNotFoundException: and
	at Method)
	at java.lang.ClassLoader.loadClass(
	at sun.misc.Launcher$AppClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(
Could not find the main class: and.  Program will exit.

Thanks by advance


I finally found what happened !
By setting the property propagateSystemProperties of the maven plugin to false (true is the default) the job can run on jenkins.


Which version of the plugin do you use?

The same version as Gatling, 2.0.0.M3a

Do you get the computed command line when launching with -X option?

Here is a screen of the command line generated

Can’t you post a gist, please? Hard to look for “and” in this… :wink:

And do you launch the gatling maven plugin directly or do you use the Jenkins plugin?

OK, so you have some System properties whose value contains blanks (Document and Setting).
I’m a bit surprised, I thought this issue resolved. Will investigate but I might need your help for testing as I don’t have a Windows computer at hand.

No pro, if you need help to test i’ll take time.
This tool is very usefull :wink: