Gatling extremely large html report


I am trying to run a simulation using 50,000 request with 100 users concurrent. It means that there are total of 50,000 * 100 = 5,000,000 requests. The html report generated is extremely heavy, weighting over 20GB.

is there a way to make more summarized html report, without generating html file for each request?

Please let me know if any specific details are missing.

Thanks, Matan

Grrrrr, I told you to provide the required information specified when joining the Google Group:!forum/gatling

Provide the version of Gatling you’re using. If you use an old one, check with a recent one.

We’re using the latest version of Gatling used is the latest one - 2.1.4

It is sad to hear there is no way to disable individual HTML reports as they totally blow up the reports folder to gigabytes of useless data, as we’re only interested in a summary and not statistics of every single request (we have around 50k of them and it’s important to run them all but not important at all to know how each one performed). We’ll have to try and clean up the final HTML report on our side since at the moment we’re not even capable to open it in a browser, it gets stuck.

Hope you consider adding this option in the future, which can be referred to as “disable individual HTML reports”.

But why do you set 50k distinct names if you don’t want the individual statistics???

That’s the nature of a test, to send N distinct requests to stress test a storage system. Sending same request N times will not give the same result. It’s only N distinct requests that represent a real-life scenario.

But once they’re all sent - we’re only checking how long it took for the suite to run, how many requests per second were served and the latency percentiles. Therefore each individual request is not of a great interest.

Are you saying if we set the same name to all request but send different this will produce a single line result?
Something like exec( http( “same name” ).get( different URL )) * 50k times?

Right, giving identical name to all distinct requests solved the problem. Thanks for the cue :slight_smile: