Gatling giving 302 and failing

I recordered this script, but everytime i run the simulation it fails. I think that the problem can be found in the authentication process, but I do not know how to make this work. Every recording I get two strings. The first one changes everytime the second one stays the same?

If you use basicAuth (which you should be doing), you shouldn’t be setting authorizationHeader too. basicAuth ends up generating an “Authorization” header too, so if you also set another one, you’ll end up with multiple values on the same request, probably causing your server to pick the first one, which might be not the one you want.

remove authorizationHeader

Dear Stephane, I would like to thank you for your quick response and advice, but…

For some kind of strange reason I am still running into
problems. After deleting the authorizationHeader (commented out in the example below) I still get simulation errors. Basically every request gives status 404 (expect for jQuery,bootstrap, does kinds of integrations), which makes me think there is something wrong with the auth. process (https/intranet/ssl:443?). Yet the run goes perfectly.

Thank you all

404 means not found, i.e. your url is incorrect.
You can lower logging level to debug in conf/logback.xml and check the url that were generated.


i am getting Uri1 not found in my script…
i recorded and and opened that script in scala IDE.I amd getting that error.