Gatling-sbt No test to run


I’m trying to run a simple gatling test from sbt, using sbt-gatling plugin.

This is the test to run:


package default

import scala.concurrent.duration._

import io.gatling.core.Predef._
import io.gatling.http.Predef._
import io.gatling.jdbc.Predef._

class RecordedSimulation extends Simulation {

val httpProtocol = http
.inferHtmlResources(BlackList("""..js""", “”"..css""", “”"..gif""", “”"..jpeg""", “”"..jpg""", “”"..ico""", “”"..woff""", “”"..(t|o)tf""", “”"..png"""), WhiteList())
.acceptEncodingHeader(“gzip, deflate”)
.userAgentHeader(“Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0”)

val uri1 = “

val scn = scenario(“RecordedSimulation”)



And the project tree:


├── build.sbt
├── project
│ ├── plugins.sbt
└── src
├── main
│ ├── java
│ └── scala
└── test
├── java
├── resources
│ ├── bodies
│ │ └── RecordedSimulation_0001_request.txt
│ ├── gatling.conf
│ └── recorder.conf
└── scala
└── default
└── RecordedSimulation.scala


When I run sbt test, no test is run.
When I run testQuick default.RecordedSimulation i get a No tests to run for gatling:testQuick

This may be totally unrelated, but it apears that recorder is not reading recorder.conf file, I’m guessing that Gatling is not reading it either, but I can’t understand why, conf files have been created using sbt copyConfigFiles

Anyone has any idea?

Okay, Configuration files must be in src/main/resources to be read by the recorder. Although, I have not resolved the main problem yet!

Finally found why no test were run, I had messed up with the dependencies.

For the record:


"io.gatling.highcharts" % "gatling-charts-highcharts" % "2.1.3" % "test"
"io.gatling"            % "gatling-test-framework"    % "2.1.3" % "test"


Were in the plugin.sbt instead of build.sbt.