Gatling unable to parse simulation.log generated by Gatling : Version 3.8.4

I am running my test using Gatling 3.8.4 which is generating simulation logs containing lines similar to

GROUP	SERVICE	1682639566631	1682639566653	22	OSERVICE	social/FeedList	1682639570968	1682639571062	OK	 
REQUEST	SERVICE	exchange/SaveFoSERVICE	social/FeedList	1682639582968	1682639582989	OK	 
GROUP	SERVICE	1682639592945	16826395929641682639591582	1682639591610	26	OK
GROUP	SERVICE	1682exchange/Get Server URL	1682639603680	1682639603757	OK	 
REQUEST	BACKEND	debugLogin	168263961exchange/Search Gallery	1682639616324	1682639616494	OK	 
REQUEST	SERVICE	exchange/Get Ignore List	1682639616599	1682639616624exchange/SaveForLater	1682639618943	1682639618958	OK	 
USER	general	START	168263963186exchange/SaveForLater	1682639628663	1682639628677	OK	 
GROUP	SERVICE	1682639621682639631927	17	OK
GROUP	SERVICE	16exchange/Get Server URL	1682639641674	1682639641689	OK	 

Sorry can’t post the entire log due to org policy
When I run the to generate logs I am encountering errors like

	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.base/java.lang.reflect.Method.invoke(
	at io.gatling.plugin.util.MainWithArgsInFile.runMain(
	at io.gatling.plugin.util.MainWithArgsInFile.main(
Caused by: java.lang.NumberFormatException: For input string: "1general"
	at java.base/java.lang.NumberFormatException.forInputString(
	at java.base/java.lang.Long.parseLong(
	at java.base/java.lang.Long.parseLong(
	at scala.collection.StringOps$.toLong$extension(StringOps.scala:928)
	at io.gatling.charts.stats.LogFileReader.$anonfun$firstPass$1(LogFileReader.scala:121)
	at scala.collection.IterableOnceOps.foreach(IterableOnce.scala:563)
	at scala.collection.IterableOnceOps.foreach$(IterableOnce.scala:561)
	at scala.collection.AbstractIterator.foreach(Iterator.scala:1293)
	at io.gatling.charts.stats.LogFileReader.firstPass(LogFileReader.scala:102)
	at io.gatling.charts.stats.LogFileReader.$anonfun$read$1(LogFileReader.scala:59)
	at io.gatling.charts.stats.LogFileReader.parseInputFiles(LogFileReader.scala:81)

This is after I ran an AWK script on top the simulation logs to filter out specific lines based on number of columns

awk -F '\t' '(/^REQUEST/ && NF == 7) || (/^USER/ && NF == 4) || (/^GROUP/ && NF == 6) || (/^*/)  { print }'

Without the awk script, the gatling sh encounters similar errors.

./gatling-charts-highcharts-bundle-3.8.4/bin/ -ro <LOG FOLDER>

Requesting assistant as it seems gatling sh is unable to parse logs generated by Gatling itself. Is there a patch or an upgrade which fixes this issue?

1 Like

Have been running into similar problem and am still rummaging every possible link available . No luck yet… Any help will be highly appreaciated

Our log file is an internal, not for you to parse. Format/content is subject to change without further notice.

Hi @slandelle

In case I might have miscommunicated, we are not trying a custom parser to parse the log files. We are using from gatling bundle to process the log files into Gatling reports.

Without simulation.log that generate issue it’s hard to analyse this.
Additional information like System, JDK etc. will be useful.
This error is shown always?
When you get demo project and try to generate report you get the same error ?
Do you try if this issue is on Gatling 3.9.5 ?

First step is indeed to upgrade to 3.9.5.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.