GatlingPropertiesBuilder not able to parse simulation.log, got “ java.nio.file.InvalidPathException: Illegal char <?> at index 56” while runing test script through jar file.

Hey Guys,

Can someone please help me regarding this issue? http://stackoverflow.com/questions/39462332/scala-gatling-gatlingpropertiesbuilder-not-able-to-parse-simulation-log-got

It’s gradle project which works perfectly fine through eclipse but I exported it as a jar file and running it through command line and it’s failing to generate HTML results.

Thanks,
Swapnil.

Hi Swapnil,

As you probably know, Gatling is our means of making a living.
We only answer to direct emails for our FrontLine customers or Support Offer subscribers.

If you’re looking for such professional support, please say so and we’ll gladly send you a quote.
Otherwise, use the community mailing list and wait for a community member to answer.

Cheers,

Thanks Stephane,

Currently, I’m individual contributor only. I’ll try my best to promote/contribute to Gatling community.

In future may be I’ll contribute to your business too.

Thanks Again,
Swapnil.


down votefavorite





I’m building following GatlingPropertiesBuilder in my gradle project and it works perfectly when I ran it through eclipse.



<br>object Engine extends App{ <br><br> val props = new GatlingPropertiesBuilder<br> props.dataDirectory("jar")<br> props.simulationClass(classOf[Injector].getName)<br><br> props.resultsDirectory("E:\\projects\\cloud\\cloud-test\\results")<br><br> Gatling.fromMap(props.build)<br> sys.exit()<br>}<br>



I have exported this project in the form of jar and when I ran the same script through jar my test execution was fine but while parsing simulation.log and exporting HTML result, I got the stack-trace as below



<br>Exception in thread "main" java.nio.file.InvalidPathException: Illegal char <?> at index 56: scalaz/syntax/ApplicativeSyn<br>tax$ApplicativeIdV$$anonfun$?$2.class<br> at sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:182)<br> at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153)<br> at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)<br> at sun.nio.fs.WindowsPath.parse(WindowsPath.java:94)<br> at sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:255)<br> at java.nio.file.Paths.get(Paths.java:84)<br> at io.gatling.commons.util.PathHelper$.string2path(PathHelper.scala:30)<br> at io.gatling.commons.util.ScanHelper$$anonfun$$nestedInanonfun$3$1.isDefinedAt(ScanHelper.scala:91)<br> at io.gatling.commons.util.ScanHelper$$anonfun$$nestedInanonfun$3$1.isDefinedAt(ScanHelper.scala:90)<br> at scala.collection.Iterator$$anon$14.hasNext(Iterator.scala:535)<br> at scala.collection.Iterator$$anon$12.hasNext(Iterator.scala:438)<br> at scala.collection.Iterator$class.foreach(Iterator.scala:893)<br> at scala.collection.AbstractIterator.foreach(Iterator.scala:1336)<br> at io.gatling.commons.util.ScanHelper$.deepCopyPackageContent(ScanHelper.scala:108)<br> at io.gatling.charts.report.ReportsGenerator.copyAssets$1(ReportsGenerator.scala:43)<br> at io.gatling.charts.report.ReportsGenerator.generateFor(ReportsGenerator.scala:58)<br> at io.gatling.app.LogFileProcessor.generateReports(RunResultProcessor.scala:64)<br> at io.gatling.app.LogFileProcessor.processRunResult(RunResultProcessor.scala:43)<br> at io.gatling.app.Gatling.start(Gatling.scala:66)<br> at io.gatling.app.Gatling$.start(Gatling.scala:57)<br> at io.gatling.app.Gatling$.fromMap(Gatling.scala:45)<br> at testautomation.Engine$.delayedEndpoint$testautomation$Engine$1(Engine.scala:43)<br> at testautomation.Engine$delayedInit$body.apply(Engine.scala:21)<br> at scala.Function0$class.apply$mcV$sp(Function0.scala:34)<br> at scala.runtime.AbstractFunction0.apply$mcV$sp(AbstractFunction0.scala:12)<br> at scala.App$$anonfun$main$1.apply(App.scala:76)<br> at scala.App$$anonfun$main$1.apply(App.scala:76)<br> at scala.collection.immutable.List.foreach(List.scala:381)<br> at scala.collection.generic.TraversableForwarder$class.foreach(TraversableForwarder.scala:35)<br> at scala.App$class.main(App.scala:76)<br> at testautomation.Engine$.main(Engine.scala:21)<br> at testautomation.Engine.main(Engine.scala)<br>



I made it sure that there should not be any whitespace in my File-Path and opened command prompt in “Administrator” mode but no luck :frowning:



Issue look similar to this one Illegal character in path at index 16 but how can I resolve here? Any help will be appreciated.