How to run the project generated from archetype from command line?

I’ve created a new project from the archetype. I know that I can run it from the IDE. It’s written how to do if here:
I’ve figured it out that I can run it from command line like this: mvn scala:run -DmainClass=Engine
My problem is that it asks additional questions. I’d like to run it with a CI server so it’s a bit problematic to interact with the Engine during the execution. Is it possible to pass the params to it somehow?

Use our maven plugin:

The archetype is intended for IDE integration.

Okay, Thanks!

  1. január 15., csütörtök 13:49:48 UTC+1 időpontban Stéphane Landelle a következőt írta:

Hi Peter,

We run gatling from Jenkins. What you have to do is instead of running the Engine, you need to specify the simulation you want to execute like this:

mvn gatling:execute -Dgatling.simulationClass=com.whatever.YourSimulation

You can also update your tests and pass in parameters that could be needed for your execution like this:

mvn gatling:execute -Dgatling.simulationClass=com.whatever.YourSimulation -Denvironment=yourenvironment



the only command that works for me is Petter suggest: mvn scala:run -DmainClass=Engine
i have tried the mvn gatling:execute … but never works for me, it cannot find it it says:

ERROR] No plugin found for prefix ‘gatling’ in the current project and in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [… central (] → [Help 1]


Diggin out the almost 3 years old thread.

Same issue here. Appears on linux and windows.It just runs fine via jenkins maven job but not via console.

It was a path issue.
mvn -f path/to/pom.xml solved it form.

I’m trying to call gatling from cmd but “prefix” problem appears.
I run my mvn cmd from parent pom but gatling depedency is set in the child pom - I understand It’s a config problem?
I added plugin group to maven settings.xml however still the same problem…
Anyone was able to fix it or narrow problem?


W dniu czwartek, 4 stycznia 2018 18:25:04 UTC+1 użytkownik Stephan D. napisał: