How to stop the run and get the results

when stopping the gatling run, it never creates the regular results as it creates when it end by itself.
is there a way to have it even i stop it in the middle?

See report-only option in configuration documentation.

but i am running it like this:

mvn test -Dgatling.simulationClass=saml2login

as it saud, there is no option -ro for example. it is just when running mvn gatling:execute… no?

Yes there is:

for now i success to do it when running the engine by the intellij UI after updating the parameter reportsOnly in the conf file.
but how to do it by command line i don’t know.
i tried this:

mvn gatling:execute -ro saml2login-1423480266566

but when i do it says that it is not a maven option.

it looks like no gatling options, just mavne options

Try changing gatling.config. There is a reportsOnly parameter that you can uncomment and add you simulation results folder.


Simple standard maven

as you see in the last post, i did it, it works by running the engine by the UI, but how to do it by command line???

It works, thanks Stephane, the posts were fast so my last post was to Gogna. forget it.

is there a tree diff between running plugin and running the engine?
i am little confuse about it because:
when i run it from engine it put the results under traget\results
when i run by cli it put it under target\gatling\results

can you check if it is really coded issue in your code or my ?

It’s not an issue, it’s just… different.
When running through the Maven Plugin, you can expect to see a lot of different files, directories and artifacts produced during the build, hence the additional level using a ‘gatling’ folder to help you find your results.

Which is not the case with the Acrhetype : It is not expected to have anything else than Gatling related code and artefacts in a project generated through the Maven Archetype.



ok understand.
so everything works fine with the cli.
anyway, in the log i get some info rows even it end with build success and the report is generated perfect:

Could NOT find resource [logback.groovy]

Could NOT find resource [logback-test.xml]

The requested class(‘saml2login’) can not be found in the classpath or does not extends Simulation.

do you know why ?

Could NOT find resource [logback.groovy]

Could NOT find resource [logback-test.xml]

Just some debug logs from the logging library that can also be configured
with those files instead of a "logback.xml".

The requested class('saml2login') can not be found in the classpath or does

not extends Simulation.

You probably still force the simulation, while you only want the reports
(so the simulation wasn't compiled).

ok thanks so as i understand it is not disturb