is it possible to get Gatling to wait more than 60 seconds for a request?

I have tweaked alle the parameters in gatling.conf that comes with default 60.000 ms to 90.000 but still I get timeout after 60.000.


check gatling.conf :

ahc {
#allowPoolingConnections = true # Allow pooling HTTP connections (keep-alive header automatically added)
#allowPoolingSslConnections = true # Allow pooling HTTPS connections (keep-alive header automatically added)
#compressionEnforced = false # Enforce gzip/deflate when Accept-Encoding header is not defined
#connectTimeout = 60000 # Timeout when establishing a connection
#pooledConnectionIdleTimeout = 60000 # Timeout when a connection stays unused in the pool
#readTimeout = 60000 # Timeout when a used connection stays idle
#connectionTTL = -1 # Max duration a connection can stay open (-1 means no limit)
#ioThreadMultiplier = 2 # Number of Netty worker threads per core
#maxConnectionsPerHost = -1 # Max number of connections per host (-1 means no limit)
#maxConnections = -1 # Max number of connections (-1 means no limit)
#maxRetry = 0 # Number of times that a request should be tried again
#requestTimeout = 60000 # Timeout of the requests
#useProxyProperties = false # When set to true, supports standard Proxy System properties
#webSocketTimeout = 60000 # Timeout when a used websocket connection stays idle
#useRelativeURIsWithConnectProxies = true # When set to true, use relative URIs when talking with an SSL proxy or a WebSocket proxy
#acceptAnyCertificate = true # When set to true, doesn’t validate SSL certificates
#httpClientCodecMaxInitialLineLength = 4096 # Maximum length of the initial line of the response (e.g. “HTTP/1.0 200 OK”)
#httpClientCodecMaxHeaderSize = 8192 # Maximum size, in bytes, of each request’s headers
#httpClientCodecMaxChunkSize = 8192 # Maximum length of the content or each chunk
#keepEncodingHeader = true # Don’t drop Encoding response header after decoding
#webSocketMaxFrameSize = 10240 # Maximum frame payload size

As allready stated, I have checked and tweaked the config, but if you read my post you can see that even when changing the config it still stops waiting for a response after 60 seconds.

Did you find a solution? I changed requestTimeout = 90000, but seems it doesn’t take effect.

Willd guess : did you uncomment the line you changed ?

Yes, I did uncomment the line.

Yes it is uncommented. Still not working...

No I did not find a solution. Did you?

No, not yet. I’m afraid the parameter is not working.

Adding the following to the gatling.conf will work.

gatling {
http {
ahc {
requestTimeout = 120000

I concur with Srinivas SV.
Uncommenting and increasing requestTImeout value in gatling.conf worked for me.

For anyone else coming across this. I had this same issue, and it was resolved by also uncommenting and setting the timeouts on pooledConnectionIdleTimeout and readTimeout. I’m not sure if both settings are required (I just followed the advice my colleague gave me), but it did make my requestTimeout value finally take effect.