JUnit runner ignore first and later runs Gatling tests when mixture of Java and Gatling tests.

I have a test packages consists of both Java and Gatling(Scala classes).

Below is my scenario with steps: src/test/java (package structure, earlier I kept the java tests src/test/java and gatling tests src/test/scala, but was having different issues wrt accessing java classes during run time)

  1. Java test classes => Load test data
  2. Gatling Tests ==> Gatling simulations using Scala
  3. Java test classes ==> Unload Test data and shutdown test instance.

When I tried to use jUnit runner as “@RunWith(StepRunner.class)”, it does the below:
Step 1 is successful,
Step 3 is successful

Then Step 2 is initiated and failed since no instance is running.

I tried with jUnit runner(import ru.pravo.qa.gatling.junit.JUnitRunner) for Gatling tests too, but same behaviour.

Is there a way I can do my executions sequentially from Step1 until Step3 properly.

Is there any configurations to be done on maven build cycle (POM.xml) file to execute it in right order.

Has anyone combined Gatling and Java in the same project/package?
Still facing issues while integrated these both.