maven plugin is logging nothing


I’m trying to get the maven plugin or just gatling to log to the file or console, but I have not had any luck. With one request in error, I just get

12:03:31.429 [gatling-http-1-2][WARN ][StatsProcessor.scala:114] i.g.h.e.r.DefaultStatsProcessor - Request ‘request_1’ failed for user 1:,201,202,203,204,205,206,207,208,209,304), found 400

on the console. I’d like to see the full response.

I’ve tried copying and uncommenting out the DEBUG line.

I’ve tried more complex logging with both ConsoleAppender and FileAppender.

I’ve tried giving the full path of the file, since I am unsure where the path starts for a relative path. I created a logs directory for the log file to go into, but nothing is ever written in there.

None of these have produced any log files or logs on the console. I’m using the gatling maven plugin version 3.0.1.

Does anyone have any suggestions? I’m happy to start again with a new file, or anything. I’m sure once I see some logs I’ll be able to modify it all to do what I want.


I’m still not able to find any log files of the response. Any ideas?