Maven plugin throws exception

Yesterday I tried to migrate from Gatling 1.2.5 to 1.5.1 due to the use of Jenkins Gatling plugin (require the generation of a file name global_stats.json).

The problem may be a trouble on versions in pom.xml files but I can’t find out what’s wrong. So I ask for your help.
You can find the sources and mvn logs in the attached file

Problem is :

  • when running I’ve got this error (more log in zip file) :

PluginContainerException: An API incompatibility was encountered while executing com.excilys.ebi.gatling:gatling-maven-plugin:1.5.1:execute: java.lang.NoSuchMethodError: org.codehaus.plexus.util.SelectorUtils.matchPatternStart(Ljava/lang/String;Ljava/lang/String;Z)Z

  • when I remove the dependency to hightcharts, the test run (but, of course, report generation fails).

I’ve the same trouble with the demo : on the commit using version 1.4.6.

Tried :

  • all the version from 1.4.5 t 1.5.1 (same error)
  • dropping maven repo cache
  • using maven 3.0.4 or 3.0.5

I was only able to run the demo on the master branch. But this is the one using milestone of Gatling 2. I prefer not to use milestone.

Please help (22.1 KB)

Did you have a look at the Migrating guide?

It looks you still have gatling libs as plugin deps instead of project deps. Could you try this out, please?

Here’s the plugin demo, looks the one you’re using is also obsolete:

The problem is solved!

It was all about deps at the plugin level instead of at the project level.
Thank you very much for the help.


Have fun!