Null figures in Graphite's Whisper files (.wsp)


I was trying to integrate Graphite with my Gatling results.
When I run the simulations, all my simulation names are shown in Graphite’s left pane.
The whisper (.wsp) files are also generated, so I guess Gatling can interact with Graphite.

But, all these wsp files contain only timestamps followed by None like-

1395228840 None
1395228900 None
1395228960 None
1395229020 None
1395229080 None
1395229140 None
. . . .
. . . .

Where can be the problem??

Hi Rajeev,

Just to be sure, in gatling.conf did you:
1/ correctly activated the Graphite data writer like that:
writers = “console, file, graphite”
2/ correctly set the host and port of the Whisper collector :

graphite {
#light = false # only send the all* stats
host = “”
port = 2003
#protocol = “tcp” # Choose between ‘tcp’ or ‘udp’
rootPathPrefix = “gatling_eclipse”
#bucketWidth = 100
#bufferSize = 8192

But as you get the metric names, I guess it’s the case.
So, now, my guess would be that you Whisper setup is not correct. Can you try to send some metrics like this :

Hi Nicolas,

First of all, its Raj. Not Rajeev.
And I tried your option and it does not appear in the whisper database.

I guess my whisper is not setup properly.
Can you guide me where do I need to check?

Hi Raj,

Sorry for the mispelling.I have no clue about your whisper issue, maybe you can try here:


Ok. thanks for the guidance though.