Passing session variables to formParam is not working

Hi Ujval,

I tried the same but and still getting the same error "No attribute named ‘Use****rName’ is defined", I don’t understood what iam doing wrong its so weird.Any suggestions please?

  1. .exec(http("Read_User").get("http://localhost:8088/s_UserDetails.txt?get")

  2.  .exec(session =>  {
  val strGlobalInputFileLine1 = session("UserLogin").as[Seq[String]]

   val UserName  =  strGlobalInputFileLine1(0)
    val Password  =  strGlobalInputFileLine1(1)
    val Client_ID =  strGlobalInputFileLine1(2)
    val NumberOfRound =  strGlobalInputFileLine1(3)

    .set("UserName", strGlobalInputFileLine1(0))
    .set("Password", strGlobalInputFileLine1(1))
    .set("Client_ID", strGlobalInputFileLine1(2))
    .set("NumberOfRound", strGlobalInputFileLine1(3))

3.  .formParam("SOURCE", "gm")
.formParam("USERNAME", "${UserName}")
.formParam("PASSWORD", "${Password}")

1:20:04.473 [ERROR] i.g.h.a.s.HttpRequestAction - 'httpRequest-3' failed to execute: No attribute named 'UserName' is defined


Its working for me.
There must have some silly mistake.

Check for some type cast Seq[String] or strGlobalInputFileLine1 variable.

Ujval Mehta