Provided arguments (-m-rf/.../target/gatling/gatling-m-rf/.../target/gatling/gatling) are not valid


I am quite new in Gatling stuff. Trying to use this with my scala-sbt project. I followed the steps mentioned on its github page. I configured all settings as follow:

sbt version:= 0.13.5


resolvers += “Sonatype OSS Snapshots” at “

addSbtPlugin(“io.gatling” % “sbt-plugin” % “1.0-SNAPSHOT”)


import io.gatling.sbt.GatlingPlugin

val test ="."))
.settings(gatlingAllSettings: _*)
.settings(resolvers += “Sonatype OSS Snapshots” at “”)
.settings(libraryDependencies ++= Seq(“io.gatling.highcharts” % “gatling-charts-highcharts” % “2.0.0-SNAPSHOT” % “test”,
“io.gatling” % “test-framework” % “1.0-SNAPSHOT” % “test”,
“io.gatling” % “gatling-bundle” % “2.0.0-SNAPSHOT” % “test” artifacts (Artifact(“gatling-bundle”, “zip”, “zip”, “bundle”))))

when I run gatling:test, it throws following error:

[info] Compiling 1 Scala source to /…/target/scala-2.10/gatling-classes…
Error: Unknown option -m
Error: Unknown option -rf
Error: Unknown argument ‘/…/target/gatling/gatling’
Try --help for more information.
[error] Provided arguments (-m-rf/…/target/gatling/gatling-m-rf/…/target/gatling/gatling) are not valid.
[info] Simulation(s) execution ended.
[error] Error during tests:
[error] gatling.DemoTest
[error] (gatling:test) sbt.TestsFailedException: Tests unsuccessful
[error] Total time: 12 s, completed 16 Jul, 2014 11:25:44 PM


class Test extends Simulation {
val httpbaseUrl = “http://”
val httpConf = http.baseURL(httpbaseUrl)

val scn = scenario(“Test demo”)
.repeat(10) {
.queryParam(“name”, “test”)



Additionally , i also used copyConfigFiles to copy gatling.conf into project resources. Please let me know what i am doing wrong here…

Thank you !

Sorry your message only made it now: it was blocked as potential spam by Google and I was only notified now.

Hi Ruchi,

The problem is that your adding Gatling’s settings to your build twice, since gatlingAllSettings are added automatically to your build settings since the plugin has been migrated to an AutoPlugin.
Remove the line with .settings(gatlingAllSettings: _*) from your build and it should be fine.



Perfect !! Thanks a lot Pierre.