Proxy Server is refusing connection

Every time I set my browser(Firefox) to use proxy, so Gatling can record the processes I get an error stating that the Proxy server is refusing connection.

I’ve googled the issue as best as I could, but for the life of me I can’t find the answer. I have tried a completely new download of Firefox, seperate profiles.

Anyone got any ideas?

I probably have misconfigured the ports.

You probably have misconfigured the ports.

The ports are configured the exact way it states in the setup. localhost 8000 and localhost 8001

So it seems you got it wrong. You’re confusing Recorder’s own single listening port, and an optional additional proxy ( like the ones some companies use to restrict Internet access).

according to that I set the port right. The ones shown there and the default one is 8000. Should I use a different port?

PK, so there’s a mistake in the doc: the image is not up-to-date. Check: “Use this proxy server for all protocols”.

Set it to localhost 8000 and use the proxy server for protocols and still get the same error =/

Please provide screen captures of your recorder and browser set up.

did you get this through ? i have the same issue with firefox…now

please find attached, screenshots of Firefox settings and Gatling Screen.

You even didn’t start the recorder by pressing the start button, or it crashed when you did so (in this case, check the logs).