sbt test:assembly throws ...resolution-cache/reports/..._2.12-test.xml

I am following the user guide for FrontLine, and added the FrontLine plugin for sbt. I updated all the versions to the latest. I am able to sbt clean compile. I can also test:compile and it:compile. But when I run sbt test:assembly, I get an error:

[error] (Test / assembly) /Users/k28500/src/fip-gatling/target/scala-2.12/resolution-cache/reports/org.finra-fip-gatling_2.12-test.xml (No such file or directory)

Similarly, I tried it:assembly, and I get: …_2.12-compile.xml (No such file or directory)

Is this a bug, or a mistake on my part?

Hi John,

After investigating, it seems that the sbt-frontline plugin is broken when used with sbt 1.3.x .
Is it possible for you to downgrade to sbt 1.2.x for the time being ?



Downgraded to sbt 1.2.8, and that seems to have solved that problem. Now I have another problem, but I’ll send that as another post.

I expect the plugin to work properly with sbt 1.3 when disabling coursier, as it uses the ivy files:

ThisBuild / useCoursier := false

Indeed. Adding that line to my build.sbt allowed it to work fine. Thanks!