SLF4J: Class path contains multiple SLF4J bindings.

I am new to this gatling and its strange it giving me a warning as 'SLF4J: Class path contains multiple SLF4J bindings."

SLF4J: Found binding in [jar:file:/C:/gatling_2.2/lib/logback-classic-1.1.3.jar!
SLF4J: Found binding in [jar:file:/C:/gatling_2.2/lib/logback-classic-1.1.7.jar!
SLF4J: See for an explanation.

Which version of gatling are you using? Are you sure you didn’t mix two of them in the same directory?

Because only logback 1.1.7 should be in your lib directory when unzipping the official bundle.


I ran into the same problem and solved it by adding an exclusion in the jmxtrans dependency:




for sbt this is my config…had the same issue…had to decide on using the logback provided by gatling over slf4j

lazy val root = (project in file(".")).enablePlugins(PlayJava,GatlingPlugin).disablePlugins(PlayLogback).settings(inConfig(Gatling)(Defaults.testSettings): _*)
scalaSource in Gatling := baseDirectory.value / "funcSpecTests"
resourceDirectory in Gatling := baseDirectory.value / "funcSpecTests/resources"