Stress test on https site fails

Hi Team,
    I am trying to do stress test on my https site. But it fails with handshake error. I think by default gatling supports https. It works fine with Do I need to set some configuration for this. I am new to this.

Thanks in Advance


What’s the error/stacktrace exactly?
Which version do you use?

11:36:48.276 [DEBUG] i.g.h.a.AsyncHandler - Request 'Demo Test' failed for user 918894289564419333-90 handshake alert: unrecognized_name at ~[na:1.7.0_65] at ~[na:1.7.0_65] at ~[na:1.7.0_65] at ~[na:1.7.0_65] at ~[na:1.7.0_65] at ~[na:1.7.0_65] at org.jboss.netty.handler.ssl.SslHandler.unwrap( ~[netty-3.9.2.Final.jar:na] at org.jboss.netty.handler.ssl.SslHandler.decode( ~[netty-3.9.2.Final.jar:na] at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode( ~[netty-3.9.2.Final.jar:na] at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived( ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at ~[netty-3.9.2.Final.jar:na] at java.util.concurrent.ThreadPoolExecutor.runWorker( [na:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor$ [na:1.7.0_65] at [na:1.7.0_65] 11:36:48.277 [WARN ] i.g.h.a.AsyncHandlerActor - Request 'Access the Token' failed: handshake alert: unrecognized_name 11:36:48.278 [DEBUG] i.g.h.a.AsyncHandlerActor - >>>>>>>>>>>>>>>>>>>>>>>>>> Request: Demo Test: KO handshake alert: unrecognized_name


Does this happen under load, or even with just one single user?

No. This is happening when trying with single request for a single user

So either you're not hitting a real https website or your https layer is utterly broken.

I had same problem earlier while testing Gatling with one of the servers. I read somewhere in one of the threads that by doing the following, we could fix it. I tried it and it worked.

Add the following line to JAVA_OPTS in gatling.bat or and re-run gatling.


Hope this helps.


Good catch Umesh.

I’m still wondering if we should disable SNI by default. I mean, the issue is with the server in the first place, with certificates being not properly configured (missing name).

I am not sure, if disabling SNI by default is a good idea. In my case, the server certificate was self-signed, which would have caused this issue. Otherwise, mostly the server certificates are issued by a valid CA. So, keeping SNI enabled definitely makes sense.


Actually, you got rejected by SNI not because you used a self-signed certificate, but because it was generated without a name, or with a name that didn’t match the hostname.
I just checked with a proper named self-signed certificate and Gatling works as expected.

Hi Stephane,

I am not quite sure what the problem is in my case then. The URL that I am hitting is a load balancer URL and there are 3 servers behind the load balancer. And all the server host names are present in the certificate (under subject alt name attribute). May be, I should try adding the CA in to the keystore.


Hi Umesh.

If you have a “unrecognized_name” error, there’s definitively something fishy on your side, like misconfigured server names or DNS.

Hi Stephane/Umesh,

We are trying to implement Gatling in one of our project and we are getting handshake failure when we are hitting our application.Our application is single signon https application where it takes credentials at the first time only.I tried passing username/pwd in url like but no luck.Please see the exact error below.Any help will be highly appreciated.Thanks in advance!

01:08:10.830 [WARN ] i.g.h.a.ResponseProcessor - Request ‘Home_Page’ failed: j.n

.ConnectException: Received fatal alert: handshake_failure