Cannot Run gatling.bat on Windows 10 64-bit Machine

I just installed Gatling 3.3.1 on a Windows 10 64-bit machine.

I have the Java jdk1.8.0_241 installed.

I can run the Gatling Recorder.

I can import a HAR file created using Google Chrome.

I can generate a .scala file from the HAR file import.

But what I cannot do is run the gatling.bat script.

When I try to run the script I get a java.lang.OutOfMemory error. unable to create a new native thread.

The machine I am using as 64 GB of RAM. I have over 58 GB free.

I have read, and read, and read, but have not found a solution.

Thanks for any help,
Randy Stevenson
Deere & Company

The machine I am using as 64 GB of RAM. I have over 58 GB free.

64 GB of RAM is a lot. Is it a huge server? You rarely find this kind of memory on laptops or desktops.
Are you confusing RAM and disk space?
The error you get is definitively because you don’t have enough free memory.

The machines we use on our team are all 64 GB RAM Engineering Class Windows 10 64-bit desktop computers, though rack-mounted. We need mongo machines because we use LoadRunner, which is just a big fat memory cow, especially when we use the TruClient protocol.

Note: It takes this much horsepower to run no more than 30 Virtual Users on a machine. This is one of the big reasons I want to try to move to Gatling.

What is weird in this particular case is that I have installed the Gatling 3.3.1 version, and cannot get the google.bat script to run, yet on another, older computer with only 32 GB RAM running Gatling 2.3, gatling.bat runs just fine with the default settings. My problem with it is that it will not let me import a .scala file.

I was hoping to get a good working Gatling set up that I can then clone to other computers.

Thanks for any help.


Thanks for the explanation.
Could you please provide the full stacktrace so we can figure out when this crash happens (when compiling the Scala code or when executing it).
If possible, could you please share your files so we can try reproducing on our side?

I am not completely sure what you mean by a “stack trace”, but I have attached a screen shot of the gatling.bat execution:

I have also attached my gatling.bat file. Note: I downloaded the same Gatling package to a different computer with the same specs (snapshot attached), and I got the same result.

What other information or files can I provide?


I just posted a reply, but Gmail would not allow me to include any attachments. I zipped them all, but still no luck.

I seem to be plagued with issues these days.

Hello again.

I installed the 3.3.1 on three other 64 GB machines. I got the same “out of memory” issue when trying to run gatling.bat.

However, I just installed it on a 32 GB machine, and everything is fine. Mostly. I imported a HAR file and it succeeded. I was able to initialize gatling.bat and choose the new simulation. It tries to run, but, as I would expect, the .scala script needs some work to get it to run.

The out of memory problem seems to be related to the large amount of RAM we have available. This is probably the first time I ever had an issue of too much memory. LOL


How much RAM do you suggest that the average desktop publishing and streaming (reception) computer need for WIndows 10.

Most use cases are fine with ~2GB of free RAM (default heap size is 1GB + some room for native non-heap memory, typically direct ByteBuffers for IO).