Error accessing other maven module by dependencies?

Its me again :slight_smile:

I’ve got the following situation:

  • I work on a multi module environment configured via maven
  • therefore I’ve got a “utils” module (written in Java) with some crazy stuff inside and a “load test” module (written in Scala) for gatling
  • I’d need some of the utils in the “load test” module (reading special config etc.), so I’ve configured dependencies to “utils” module

But all I get is a compilation error:
[INFO] 10:33:17.180 [main][ERROR][slf4j.scala:105] c.e.e.g.a.ZincCompiler$ - project-load-test\src\loadtest\scala\net\company\project\loadtest\config\LoadTestConfiguration.scala:6: object util is not a member of package
[INFO] 10:33:17.182 [main][ERROR][slf4j.scala:105] c.e.e.g.a.ZincCompiler$ - import
[INFO] 10:33:17.188 [main][ERROR][slf4j.scala:105] c.e.e.g.a.ZincCompiler$ - ^

It neither works with the CLI nor calling “mvn gatling:execute”.

How can I solve this?

Regards Danny

Have you tried adding the dep to the plugins deps, not the project one?

It seems to work though - but I had to import it for project AND plugin.
Within the project the dependencies can be solved for the editor and within the plugin for the gatling runtime.

Many thanks,

The gatling maven plugin is based on ant (seemed a convenient wait to set
up distinct JVM options).
It would be great if we could find a way to propagate the project test
classpath to Gatling.

Will try, stay tuned.