Error when running simulation


I am getting the following error when running a simulation :

“ handshake alert: unrecognized_name”

The site I am trying to reach does require the acceptance of a certificate. Is there anything I need to do to configure gatling to auto accept the certificate?

Thank you for your time!

Thank you for the link! I am not a developer so please excuse my ignorance but I am able to run the test successfully by using the ip address of the application and not the url. Why is that?

Thank you for your time!

Java 7 enables by default SNI (Server Name Indication), an extensions to TLS. But as SNI deals with communicating the server’s hostname to the client, if there’s no hostname because you’re using its IP, there’s no need for SNI apparently.

Tldr: disable it with the System property

Would it be possible to give a step by step on how to do that? I’m not quite sure where to start.

Thank you!

The first answer in this SOF thread explains how you can either pass the System property in the command line (edit Gatling launch scripts) or add it programmatically (in the Simulation class then).