Feeder file missing to populate in POST .formParams

Sorry For the BigEmail but wanted to put in all the details to share the complete picture.

I am using a maven archetype to create my project . I am on scala 3.3.1

here’s my Project structure :

image.png

My Issue

I have a feeder file which sometimes fails to populate the data in the exec POST calls. I tried circular and also random . ( val upFeeder = csv(“data/usrpwd.csv”).random)

How I found this Issue

Found the formParam in my POST requests missing in my server logs , hence created this chainBuilder and a scenario to prove it the issue with the Feeder File.
<wul:Failure iPhone_XXXX=“Please enter your user name” Location="/35k_0710_tm/login-auth.xml" Reason=“IllegalArgumentException”>Please enter your user name</wul:Failure></wul:Auth_Response>

image.png

How did i conclude its the gatline feeder causing this error?
1 .Just to validate my AUT, I hard coded my POST exec form params and ran a heavy test and they work very like charm.I’m more confident its something witht he feeder file usage.
2 . In order to check the gatling side of things , I removed all my app logics and created this simple feederTest.

STEPS

  1. I could reproduce the feeder issue by creating a dummy test for feeder file.

Feeder file : Place few (or even just one logline) entry in this csv file with headers ( userName , password)
In my feeder file There is no blank line at the end of the csv file.
$ cat usrpwd.csv
username,password
u00001,somepassword
u00002,somepassword

Hello,

First of all, please upgrade to Gatling 3.4.0 as you’re using a deprecated version.
Then, if you can still reproduce, please check your feeder file for non printable characters that could break the csv parsing or your printing (ie what you send if not what you see).
If you can’t spot anything suspicious, please provide your feeder file.

I upgraded to 3.4 . It complained about some compatibility at the “IDEPathHelper.scala” files .
I fixed it by copying these files from the mvn:gatling repo from https://github.com/gatling/gatling-maven-plugin-demo/tree/master/src/test/scala

Ran the same test with same feeder files and it worked with charm .

Thanks again.
Issue Resolution : Upgraded to latest gatling version 3.4