Migration to Gatling 3.0.0-RC3. Get a value from a CSV file.

Gatling 3.0.0-RC3
gatling-sbt 3.0.0
I am migrating to new version of Gatling and I need help with csv feeder.

I have some csv file.
for example:

My code when I use feeder look like this(Gatling 2.3.1):

.exec(session => {
  val ssn = session.get("Ssn").asOption[String]
  println(s"""SSN: ${ssn.getOrElse("COULD NOT FIND ID: SSN")}""")
.exec(new PaymentServiceProvider Reserve("${PaymentId}", "${requestId}",
  ReserveBody("${Ssn}", "${komIdSubject}", "4")))

For gatling 3 I removed "get" frome the session

For gatling 2.3.1 and for gatling-sbt 2.2.2  worked ok. They print "Ssn" number from the file. But for gatling 3 I have problem they print all the time response from println line "SSN: COULD NOT FIND ID: SSN". 
I don't know where is the problem. I am trying to change format of the file, path but nothing helps.

Best Regards

And also print Reserve: Failed to build request: No attribute named ‘Ssn’ is defined

W dniu środa, 10 października 2018 10:51:03 UTC+2 użytkownik Daniel Safiński napisał:

Please provide an actionable reproducer, eg fork the https://github.com/gatling/gatling-sbt-plugin-demo


Note that your file looks super suspicious:


Why do you mix commas and semicolons???
I suspect you use semicolon separators, so your file has one single column "Ssn,CountryCode

Hi Stephane,
Thanks for response.

Why do you mix commas and semicolons???
Because someone delivered to me this file as csv in this format and I used this in G2.3.2 and it worked ok.
In gatling3 I tried different formats also only with comma as you mentioned and it doesn’t work.

Any suggestion?
W dniu środa, 10 października 2018 11:08:47 UTC+2 użytkownik Stéphane Landelle napisał:

Does your file have a BOM?

OK, that’s definitively some BOM crap, see https://github.com/gatling/gatling/issues/3559

Yes, definitely. Yesterday I took csv file from the gatling-sbt-plugin-demo project and pasted my data and feeder loaded properly . Thanks again for help.
W dniu środa, 10 października 2018 22:36:53 UTC+2 użytkownik Stéphane Landelle napisał: