Gatling load test issue with WildFly


We faced issues with WildFly 16 load test with Gatling. The same worked fine on WildFly 8.2.
With WildFly 16, post login calls are redirecting to the login page when running load test. Looks like the session is not available. It works fine when we record tests, issue is when running the Gatling test.
Is there any way to check session passed with requests?

Only difference is the WildFly version. In the WildFly-16, there is some new features like HTTP2 support.
Any hint on what may be the cause for this will be helpful.


“What has changed between WildFly 8.2 and 16 regarding session creation?” looks like a question that would be better asked on a WildFly mailing list.
Please share your findings though.

In WildFly-16, there is support for HTTP/2. That is one difference I can see when checking the old and new versions.
Post login requests via Gatling fails as if there is no session.

As required in this group’s terms:

  • Provide a Short, Self Contained, Correct (Compilable), Example (see

Sorry, I don’t have any exception to share. It’s an application specific post login test case which not worked as if there is no session when tested after WildFly upgrade. All works fine when we do manually.