Getting Error$ - Run crashed

While trying to run gatling test using mvn gatling:test I am getting this error
Gatling Version: 3.6.1
Java version : 11
Scala version: 2.13.9
19:48:10.831 [main] ERROR$ - Run crashed
Caused by: java.lang.ClassNotFoundException: io.netty.internal.tcnative.CertificateCompressionAlgo
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
at java.base/java.lang.ClassLoader.loadClass(

You have an issue with the io.netty:netty-tcnative-classes artifact.

  • either its missing from your dependencies because you’ve messed up with the dependency management, to be checked with mvn dependency:tree
  • or the entry in your local maven cache is corrupted, to be checked if you can unzip it, in this case delete it so maven downloads it again

In the dependency tree I can see
± io.netty:netty-tcnative-classes:jar:2.0.55.Final:compile
Still getting the error

What about the second part of my message?

Once you’ve solved this, make sure the netty and netty-tcnative modules are compatible, in particular if you’re messing up with the versions with some dependencyManagement or importing other librairies that depend on netty too (hint: you shouldn’t).

I tried invalidating cache in intellij and delete .m2 folder to remove local cached dependency.
But nothing seems to work
I have

From what I checked they both are compatible.

After few changes I have started getting this error
java.lang.NoSuchMethodError: ‘boolean io.netty.internal.tcnative.SSLContext.setCurvesList(long, java.lang.String)’

Can you please help

Why don’t you let Gatling handle the netty and netty-tcnative versions? You’re looking for trouble. You have zero guarantee that Gatling 3.6.1 is going to work with these versions.

Any other combination is not supported and for you to figure out.

If you want to use up-to-date netty versions, you should upgrade Gatling first.

FYI @slandelle
I tried using gatling 3.9.5 but it had its own issues and I ended up getting
java.lang.RuntimeException: Can’t find the jar matching scala-library-.*.jar$
So I read somewhere to downgrade the version so I moved to 3.6.1

Why don’t you let Gatling handle the netty and netty-tcnative versions?
Because I am working on a project where we already had these dependency in use from before, So I can not remove it.

Sorry, but I’m afraid that there’s no way to help you unless you go with a paying consulting contract where we can investigate your setup indepth.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.