Gradle build error from demo project - same

I installed the demo and opened in intellij
in the terminal I am attempting to execute > gradle gatlingRun

I get this:
A problem occurred configuring root project ‘gatling-gradle-plugin-demo-kotlin’.

java.util.concurrent.ExecutionException: org.gradle.api.GradleException: Failed to create Jar file C:\Users\punchbuggyred\.gradle\caches\jars-9\87491e8cdb0229bafcb7120e23222513\jackson-core-2.15.2.jar

Gradle 8.4
JDK 17
Kotlin 1.8.10

Any help is appreciated.

I found another thread that matches, but the solution wasn’t clear and I tried the suggestions in the thread.

Hi @enader,

This topic would find its place in the gradle support. (it’s not specific to gatling)
It seems that gradle cannot write in the mentioned directory. Usually, there is an issue with the permissions or with the available disk space.

Can you try to delete this caches directory? (Gradle will gladly recreate it on the next command)
Then try again.


Thank you for your quick reply. So I need to find a gradle support forum? I’ll take a look.
I deleted the caches and they were re-created. I’ll try that again anyway.
I also ran intellij as administrator. I thought it may be a permissions thing. There is a .lock file created in the 87491e8cdb0229bafcb7120e23222513 directory, but since its a .jar there may be other computer permissions imposed from the company.

I’ll also look into installing gradle cache in a different location that jars can be created.

I also copied that jar into that folder. I still get the error. Do you know why? If the jar exists why is it being created?

Try lowering the logging level, see Logging
Maybe you would get better hints about what happens.

And maybe reach out to other gradle users in your organization who might be aware of what kind of tuning you need to be able to use gradle there. Your problem has probably something to do with disk permissions or antivirus.


I found a work around.

  1. Manually copy jackson-core-2.15.2.jar to the location.
  2. Manually create an empty file called jackson-core-2.15.2.jar.receipt to the same location

This worked. The error disappeared. Its not ideal, but it worked.

Thanks for your input. After removing the caches all the caches were re-created except for jackson-core-2.15.2.jar. So I assume that if it was a permission thing then no other jar files would have been downloaded. I also assume its not a disk permission issue because I can manually copy the jar to that location. So this is still weird. But at least there is a work around, see below.

Any chance you’re actually using a corporate maven artifact proxy such as Sonatype Nexus or JFrog Artifactory? Maybe a corrupted jackson-core-2.15.2 jar is stored there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.