i.g.h.c.i.RequestTimeoutException Error

Hi Team,
I am running the test for the application since couple of days and my test will stop after the below error and failed.my load injector is configured in AWS EC2 instance this test is configured for 8 hours of test but after the 5 hours execution it will throw the below error .

I tried to search on different forum but still not figured out what and where is the issue.
Any help will be appreciated as my test is critical for go live


i.g.h.c.i.RequestTimeoutException: Request timeout to rfo.mana 1 (33.33%)
i.g.h.c.i.RequestTimeoutException: Request timeout to rfo.mana 1 (33.33%)

Hi Santosh,

Hard to know what can be wrong with such a log only.
Please help us to help you!

Gatling version?
Platform? (windows, macOS, linux? Which flavor?)
Which launcher? (sbt, gradle, maven, bundle, Gatling Enterprise; version and flavor?)

Can you provide a reproducer as requested in our guide?

For soak test (long running test with few users), we generally remove all exitHereIfFail as we don’t want to stop the whole simulation if one user fail.

Do you own every server called by your simulation? Do you manage all the policy rules?
Often, third party servers are protected against (D)DoS or other strange behavior.
Having the same IP regularly call your server is a “strange” behavior when it lasts for hours.

Lots of different things can be a cause, here.
So, we need more information to help you.


Also, being curious, can you try enabling the asyncnameresolution.

I’m wondering if your website’s IP adresses could be rotating and you have a DNS cache expiration issue.

Hello Sébastien,

Thanks so much for your quick reply .please find my details below.
Gatling Version-gatling-chart-highcharts.bundle-3.7.6
Launcher-maven 3.8.6

As far as reproducer i need to check as its Smart Card Identity solution and everything is serverless(AWS Lambada) without smart card authentication application login is not allowed.

It’s 8 hrs test with 45 vu with parallel scenarios execution,i noticed first 5 hrs test executed without any error and its hanged for some time and throws this error and all test failed.

All the AWS infra managed by the Platform team and provided the requested configuration for execution to me.

As part of the framework its mainly using AWS components-Lambada,API gateways,VPC,Dynamodb,S3 bucket,Rout53,Cloudfront and many more.


@ksanty1978 Please try as advised in my prior message. If you still face the issue, you’ll have to investigate with your platform team. We can’t help with your platform outside of a contract.

Hello slandelle,
Thanks so much for update and details.Let me review with platfrom team share the update.