Maven Plugin Recorder argument issue


I believe theres an issue with the arguments in the recorder goal for the gatling maven plugin.

[INFO] — gatling-maven-plugin:3.1.1:recorder (default-cli) —
Warning: Unknown option -rsf
Warning: Unknown argument ‘repos/QA/gatling/src/test/resources’

When I run from the bundle, i see the option for -rf but not -rsf.

I wasnt able to submit a github issue.

Anyone know if I am missing something or its just a bug?


Have you tried mvn gatling:help?

yea, though its: mvn gatling:recorder thats throwing the warning and not using the correct resource directory.

% mvn gatling:help

This plugin has 4 goals:

Display help information on gatling-maven-plugin.
Call mvn gatling:help -Ddetail=true -Dgoal= to display parameter

Mojo to run Gatling Recorder.

Mojo to execute Gatling.

Mojo to verify Gatling simulation results.

mvn gatling:recorder -DresourcesFolder=’/Users/repos/QA/gatling/src/test/resources/’

its the resourceFolder option, but it doesnt seem to be working, ive also defined it in the pom.xml.

That’s a bug indeed.
Thanks for reporting.

Please upgrade gatling-maven-plugin to 3.1.2.

Thanks for the quick response! Works for me now.