Migration doIf from Gatling 1.5.3 to 2.0.0M3a

Hi there,
in Gatling 1.5.3 the following scenario worked well

val addProfile = {
.fileBody(“addProfile”, Map(“lon” → “${lon}”,“lat” → “${lat}”)).asJSON

val scn = scenario(“get profile”)
.check(status.saveAs(“status”), status.in(Seq(200,404)))

In Gatling 2 I get an error “value doIf not found”
How to transform doIf control structures for Gatling 2

Thanks in advance

You’d better check the temporary Gatling 2 page: https://github.com/excilys/gatling/wiki/Gatling%202

Note that you’ve been using fileBody and Scalate templates. Those go away in Gatling 2: https://github.com/excilys/gatling/wiki/Gatling%202#wiki-bodies.

Then in 2M3, you have to add additional imports, such as:
import bootstrap._

But those go away in upcoming 2M4.

Finally, there’s a missing closing parenthesis: .check(status.saveAs(“status”), status.in(Seq(200,404)))) ← here

Thanks for your help again.
the par-error was an artifact due to cut&past, but completion in Eclipse solved my problem with doIf

.doIf("${status}", “404”)(exec(addProfile))