Only the provided example solutions show up when I run gatling


I am new to gatling, and have successfully ran the example scenarios as well as created a scenario myself with the recorder. My problem is that when I run gatling.bat through the command prompt, only the BasicSimulation and AdvancedSimulation steps 1-5 show up as available to run. I made sure my recorded scenario was in user-files/simulations/computerdatabase folder. I changed the name of the BasicSimulation.scala file to see if it would still show up, and when I ran gatling:

Choose a simulation number:
[0] computerdatabase.advanced.AdvancedSimulationStep01
[1] computerdatabase.advanced.AdvancedSimulationStep02
[2] computerdatabase.advanced.AdvancedSimulationStep03
[3] computerdatabase.advanced.AdvancedSimulationStep04
[4] computerdatabase.advanced.AdvancedSimulationStep05

This remained the case even after I changed BasicSimulation back to the original name. Attached is a zip file of my gatling folder stored in my local C: drive.

My question is this: Why will only the provided example simulations show up when I run gatling.bat?

Jon (22 Bytes)

I did it the opposite way. I moved the computerdatabase folder to a safe place outside of the simulations folder. I created my own sub-folder under simulations (system1, system2, etc.) and placed my own recordings in them. When I run gatling I just get my simulations. If I were to copy computerdatabase folder back into the simulations folder they show up along with my own tests.

try creating your own sub folders and recording to them rather than using the computerdatabase folder that came with the install.