Running Gatling on Jenkins w/o plugin


I had to create job for Jenkins, which is running gatling by calling it from submodule. At first I tried maven-plugin, which is capable of running maven with custom POM. I set submodule POM as POM to be used and tried to execute the job. Gatling failed with “No simulations to run”.

My second attempt was to create a trigger for a job, which would run in workspace of my submodule. So, my first job, let’s name is PRJ-PerfTests triggers the other job PRJ-PerfTests-Execute, which runs on the same node with workspaces of gatling submodule. This works with maven-plugin and all the tests are being executed properly.

To be clearer, pipeline is:

(PRJ-PerfTests): clone project → trigger job on the same node
(PRJ-PerfTests-Execute): set workspace as /jenkins/jobs/PRJ-PerfTests/workspace/pt-submodule → run maven-plugin.

However, it’s a really bad solution as it ties up on directory structure, nodes, etc. and kinda forbidden by our standards. Neither I can install gatling plugin.

You might think of manual execution of maven via “Execute shell…” and writing script like:

cd pt-submodule/
mvn clean install

I cannot do so as I need to copy custom settings file to node (we have master-slave configuration) and I cannot do it manually.

What is the reason of such behaviour and how can I fix it? Have you ever tried configuring gatling execution on Jenkins w/o plugin?