Tune HTTP connection and request timeout in scenarios


I need to change the default values for the HTTP connection and request timeout. I saw that this is possible in the gatling.conf file but do you know if this can be done directly in the scenario ?

Hi Jeff,

No, you can’t do it in the Simulation.

The reason for this kind of tuning not being available in HttpProtocolConfiguration is because it’s scenario scoped while the Http client is a singleton.

Note that you can also override config file params with System properties (-Dgatling.http.connectionTimeout=120000).

Does this help?



2012/10/26 Jeff MAURY <jeffmaury@gmail.com>

Hi Jeff,

Were you able to successfully over write the timeout settings? I tried running it both by manually modifying the “gatling-charts-highcharts-2.0.0-M3a/conf/gatling.conf” file and by passing ‘-Dgatling.http.requestTimeoutInMs=300’ argument during test run but I still see the ‘Request reached idle time out of 60000 ms after 60570 ms’ message in my gatling test run.

@Stephane: Is there anything else I can do to over write the request timeout please?


You’re running a very old Gatling version. That was fixed a long time ago.

So the version I am using does not let over writing config parameters and I need to upgrade to a recent version to make this happen?

I can try a later version assuming it is backward compatible and my test code continues to function as expected.