Unexpected akka-related exception on running a simulation

Running the sample at https://github.com/witokondoria/gatlingELtest/tree/mvn-profiles, Im getting this exception:

[GatlingSystem-akka.actor.default-dispatcher-5] [akka://GatlingSystem/user/foreach-1] illegal actor name [foreach-1#inner], must conform to (?:[-\w:@&=+,.!~’_;]|%\p{XDigit}{2})(?:[-\w:@&=+,.!~’$;]|%\p{XDigit}{2})*
akka.actor.InvalidActorNameException: illegal actor name [foreach-1#inner], must conform to (?:[-\w:@&=+,.!~*’

Last time I run this sucessfully (without modifying the simulation code) was about 10 - 15 days. Could you point me what changes were made at gatling-higcharts 2.1.0-snapshot so this error appeared?


Forgot to say that this sample is a maven project runnable by mvn test -PPRE

Hi Javier,

This has been introduced by a recent commit, fixed very soon after.
But it looks like you don’t have the very latest snapshot.
Rerun with -U to fetch the very latest snapshot : mvn -U test -PPRE

And when relying on snapshots, make sure you ALWAYS use the -U flag to fetch the latest snapshots :wink:



I though it had already fetched last versions. Anyway I ran mvn -U test -PRE, resulting in this artifact being at my local maven repo:



But ending with the same error.

After investigating a bit further, this bug wasn’t completely fixed.
I just commited a fix, a new snapshot should be available in a few minutes on Sonatype.


Awesome. I confirm it fixed the error on my side.