Atmosphere long polling


This is the usual “I’m doing something without understanding it at all” post, so apologies up front.

I’ve been writing some performance tests with Gatling and until now it’s all gone well. However, I’m trying to test a page with some sort of ajax request - and the ‘proceed’ button (the element I need to click to proceed in the app) is only enabled once this request has finished.

The test times out when trying to replicate the request, even though it’s almost instant on the actual page. The Gatling recorder also gives up at this point.

The bit that I think is causing the problem:

http(“Continue Atmosphere”)
.queryParam(""“X-Atmosphere-Transport”"", “”“long-polling”"")
.queryParam(""“X-Atmosphere-Framework”"", “”“2.1.4-javascript”"")
.queryParam(""“X-Atmosphere-TrackMessageSize”"", “”“true”"")
.queryParam(""“X-atmo-protocol”"", “”“true”"")
.queryParam(""“X-Atmosphere-tracking-id”"", session=>{session}.getAttribute(“trackingId”).toString)

.queryParam(""“X-Cache-Date”"", “”“0"”")
.queryParam("""_""", “”“2"”")
).exec( session => {


where execWIthDefaults is:

def execWithDefaults(request: GetHttpRequestBuilder): ChainBuilder = {
.basicAuth(, )


And “trackingId” is captured in a previous regex.

Output from the run:

10:08:03.596 [INFO ] c.e.e.g.h.a.HttpRequestAction - Sending Request ‘Continue Atmosphere’: Scenario ‘standard’, UserId #1

10:09:03.617 [WARN ] c.e.e.g.h.a.GatlingAsyncHandler - Request ‘Continue Atmosphere’ failed

java.util.concurrent.TimeoutException: Request timeout of 60000 ms

at com.ning.http.client.providers.netty.timeout.TimeoutTimerTask.expire( [async-http-client-1.8.3.jar:na]

at [async-http-client-1.8.3.jar:na]

at org.jboss.netty.util.HashedWheelTimer$HashedWheelTimeout.expire( [netty-3.9.0.Final.jar:na]

at org.jboss.netty.util.HashedWheelTimer$Worker.notifyExpiredTimeouts( [netty-3.9.0.Final.jar:na]

at org.jboss.netty.util.HashedWheelTimer$ [netty-3.9.0.Final.jar:na]

at [netty-3.9.0.Final.jar:na]

at [na:1.7.0_55]

10:09:03.620 [WARN ] c.e.e.g.h.a.GatlingAsyncHandlerActor - Request ‘Continue Atmosphere’ failed : Request timeout of 60000 ms

10:09:03.621 [TRACE] c.e.e.g.h.a.GatlingAsyncHandlerActor -


Jean-François hates me for that, but I still don’t know much about Atmo…

We’re in RC phase for Gatling 2. Have you tried with latest snapshot?

Is there any way you can share a reproducer, please?


I haven’t yet tried v2 - I’ll give that a go. Thanks for replying so quickly!