Debugging Graphite connection

I have gatling config:

data {
writers = “console, file, graphite”
readers = file
graphite {
host = “localhost”
port = 2003
light = false
protocol = “tcp”
rootPathPrefix = “gatling”
bucketWidth = 100
bufferSize = 8192

And running netcat locally:

$ nc -l localhost 2003

I can successfully connect to netcat using telnet.

$ telnet localhost 2003

I have turned gatling logging up to TRACE. When I run gatling, I see no data in netcat, and nothing in gatling’s logs about graphite.

I have also tried (without luck):

  • setting the host setting to, and running netcat with corresponding settings
  • setting the host setting to my local IP address, and running netcat with corresponding settings

I’m fairly sure my gatling config is being used - if I put nonsense in my gatling.conf file, I get an error like this:

Exception in thread “main” com.typesafe.config.ConfigException$Parse: gatling.conf: 3: Key ‘nonsense’ may not be followed by token: ‘data’ (if you intended ‘data’ to be part of the value for ‘nonsense’, try enclosing the value in double quotes)

Any tips on how to debug this?