error running gatling.bat 2.2.2

I’m getting several errors in gatling.bat that prevent executing the script. After installing version 2.2.2, and running the quickstart record session, I opened a command window as administrator, and attempted to run the playback script,but get an error about “the input line is too long”:

GATLING_HOME is set to “C:\Users\Steve Work\Documents\gatling-charts-highcharts-bundle-2.2.2”

JAVA = “java”

The input line is too long.


goto exit


echo GATLING_HOME environment variable is not set and could not be guessed automatically.

echo Please set GATLING_HOME and try to launch Gatling again.

goto exit


if not defined NO_PAUSE pause


exit /b 0



goto :EOF

was unexpected at this time.

The same error occurs with the latest 2.2.3 snapshot. Any ideas on how to address or fix this?

Thanks in advance.

Steve K.

What’s your Windows version?
Can you reproduce with older Gatling versions, like 2.1.7?

I’m running Win10, and had a copy of 2.1.7 installed. I tried running the older script once, and it appeared to execute properly even with %GATLING_HOME% pointing to the 2.2.2 directory, but then I followed your site’s instructions and removed the 2.1.7 It did not experience this error when running gatling.bat.

I did a quick file compare between the 2.1.7 and 2.2.2 versions of the batch file, and saw there were differences in how %JAVA_OPTS% was assembled, and in the parameters surrounding the execution command. Not sure if that was a result of deprecating support for JDK7, or if the changes were driven by the updated gatling code.

Steve K.

Follow-on (and likely solution)… I changed the gatling.bat script line 1 from “echo off” to “echo on” to see where the failure was occurring, and it was happening in the for-loop (~line 63) which builds the %COMPILATION_CLASSPATH% variable. Dumping that variable out to a text file enabled me to see that the %COMPILATION_CLASSPATH% grew to over 8200 characters long.

According to , that’s too many characters. My solution is to move the gatling_charts subdirectory up in the folder structure. This cut the length down to 5200 characters – small enough to no longer crash.

I didn’t look to see if Microsoft provides any usable alternative, but my work-around seems to avoid the problem.

Steve K.

Thanks for digging into this.
Logged in our bug tracker:

Hi Steve,

Im facing similar issue, however not able to resolve as you have mentioned. Can you pls help me…What exactly needs to be done. Gatling version is 2.2.5

Are you availalbe on Skype?

I renamed the folders, instead of having gatling-fullname-etc-etc. Removed all that and made the full path shorter. And it worked

Might be of help -