New user on Windows - running gatling.bat displays Java usage instructions


First time i’ve tried to run gatling, unfortunately i’m using Windows 7, when I run gatling.bat the Java usage instructions appear:

Any idea how I fix this?



It looks like your JAVA_HOME may not be set correctly. I would think your JAVA_HOME variable should output a directory to your JAVA installation. Make sure java is installed and your JAVA_HOME is set correctly


Yep, your JAVA_HOME is wrongly set to the “JAVA_HOME” string, instead of the path of the JDK root.

I’ve given up with Windows, I spent hours trying to get it working.

Tried it out on a Mac and had Gatling up and running in less than 5 minutes.

Incidentally, this is my JAVA_HOME:

I guess that the “JAVA_HOME is set to JAVA_HOME” is misleading and actually something you added yourself (and is broken).
It’s impossible to guess what happens without further information. Please provide a way to reproduce.

I’ve cleaned everything down (uninstalled all versions of Java, removed gatling).

Installed 64bit JDK 8u101 found here
Extracted Gatling to C:\gatling-charts-highcharts-bundle-2.2.2
Changed JAVA_HOME system variable to C:\Program Files\Java\jdk1.8.0_101

Tried to run gatling.bat and I got the same as before, Java usage instructions.

Are there any further details you need?

I have the same issue as well. My host machine on WIN2012 R2.

try the following command “echo %JAVA_HOME%” and verify it prints out a path. If it does, then the JAVA_HOME variable should be correct. Then try “java -version” and verify it is version 8. Also, are you running gatling.bat in the “normal” command window or in Windows Powershell? That could affect things. If nothing else, the gatling.bat file would need looking at closely. maybe try to following software to help with that:

Nah, see