Experiencing problem with logback.xml


I’ve tried to set the root level on Debug to understand what was wrong in my simulation but it seems that nothing change on the logger in my console.

Is there something to do on the maven plugin config to make that change active ?

My logback.xml is located in src/main/resources.

Thanks by advance on any help


The problem is that we have included a logback.xml in the maven plugin (root level : warn) so your logback.xml set to debug doesn’t change anything : at your level, there’s nothing more to log.

But you can override the logback.xml included :
1/ with java -Dlogback.configurationFile=/path/to/config.xml
2/ with a logback-test.xml or logback.groovy in your classpath (Logback searches for these before searching for logback.xml, so the one included in the plugin jar would simply be skipped)

Thanks, this setup works well and i can know investigate what’s wrong in my simulation.



Just a last question, i imagine it’s the same for the gatlig.conf file ?In this case, what is the name of the vmarg to set ?

Thanks by advance,



It’s no longer possible to specify the gatling.conf location.
However, every gatling.conf property can be overriding from the command line. For example, you can set -Dgatling.simulation.outputDirectoryBaseName=foo

Does this help?



i’ve tried this morning with Gatling 1.3.5 to set a JvmArg -Dgatling.http.provider=Apache to switch from Netty to Apache but it seems that it is still being used Netty.

Is there something i didn’t understand ?

Strange, that should work.
Did you properly add commons-httpclient *3.X *in your classpath? Beware
that AHC is not compatible with httpclient 4.X.